import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".+sites\\/.+\\/archive\\/(?!folder).+";
final String string = "/sites/site1/archive/folder/\n"
+ "/sites/site1/archive/other/\n"
+ "/sites/site2/archive/folder/\n"
+ "/sites/site2/archive/other/\n"
+ "/sites/site3/other/folder/";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}