using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*(?<![a-zA-Z])top(?![a-zA-Z]).*";
string input = @"abc top aedf
top
top-blue
blue-top
my top
light-grn-top
top-cotton
green top 0192
village_top1993
laptop
laptop-glossy
desktop 45WAI
topbest";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}