use strict;
my $str = 'abc top aedf
top
top-blue
blue-top
my top
light-grn-top
top-cotton
green top 0192
village_top1993
laptop
laptop-glossy
desktop 45WAI
topbest';
my $regex = qr/.*(?<![a-zA-Z])top(?![a-zA-Z]).*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}