$re = '/.*(?<![a-zA-Z])top(?![a-zA-Z]).*/m';
$str = 'abc top aedf
top
top-blue
blue-top
my top
light-grn-top
top-cotton
green top 0192
village_top1993
laptop
laptop-glossy
desktop 45WAI
topbest';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);