using System;
using System.Text.RegularExpressions;
public class Example
{
    public static void Main()
    {
        string pattern = @"^([^;,\n]*)(;.*\b\1\b=|;.*;|;)([^;=,\n]+)(,.*|;)?$";
        string input = @"# with k/v pairs declared
http-metrics;http-metrics=/~/healthy;
http-metrics;http-metrics=/~/read;
http-metrics;http-metrics=/ping,http-service=/ping,proxy-test=/proxy
http-service;http-metrics=/ping2,http-service=/ping
http-service;http-metrics=/ping2,http-test=/ping
http-metrics;;http-metrics=/~/healthy
http-metrics;http-metrics=/~/read;
http-metrics;;http-service=/ping
http-metrics;;/ping
http-metrics;/ping;
;;/~/healthy
;/~/healthy;";
        RegexOptions options = RegexOptions.Multiline;
        
        foreach (Match m in Regex.Matches(input, pattern, options))
        {
            Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
        }
    }
}