using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*\b(?:opt1|opt2|opt3)\b\s*(.*?)\s*because_of_this\b";
string input = @"other text opt1 opt2 opt3 I_want_only_this_text because_of_this";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}