const regex = /.*\b(?:opt1|opt2|opt3)\b\s*(.*?)\s*because_of_this\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*\\b(?:opt1|opt2|opt3)\\b\\s*(.*?)\\s*because_of_this\\b', 'gm')
const str = `other text opt1 opt2 opt3 I_want_only_this_text because_of_this`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}