package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*\b(?:opt1|opt2|opt3)\b\s*(.*?)\s*because_of_this\b`)
var str = `other text opt1 opt2 opt3 I_want_only_this_text because_of_this`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}