#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[a-z](?![a-z\d]*\d$)[a-z\d]*$"
Local $sString = "ahmed0saber" & @CRLF & _
"0ahmedsaber" & @CRLF & _
"ahmedsaber0" & @CRLF & _
"ahmed_saber" & @CRLF & _
"a"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")