using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[a-z](?![a-z\d]*\d$)[a-z\d]*$";
string input = @"ahmed0saber
0ahmedsaber
ahmedsaber0
ahmed_saber
a";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}