re = /^[a-z](?![a-z\d]*\d$)[a-z\d]*$/m
str = 'ahmed0saber
0ahmedsaber
ahmedsaber0
ahmed_saber
a'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end