using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @""".*?""(*SKIP)(*FAIL)|(\(|\))| ";
string input = @"+test +word any -sampe (+toto +titi ""generic test"") -column:""test this"" (+data id:1234)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}