package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)".*?"(*SKIP)(*FAIL)|(\(|\))| `)
var str = `+test +word any -sampe (+toto +titi "generic test") -column:"test this" (+data id:1234)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}