re = /".*?"(*SKIP)(*FAIL)|(\(|\))| /m
str = '+test +word any -sampe (+toto +titi "generic test") -column:"test this" (+data id:1234)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end