import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?|(?<=null,)(.*?)(?=,null,(?:[0-9]{1,3})(?:,|$))|(?<=chara\":|motion\":)([^,\\n]*))";
final String string = "},null,\"「奇跡? ……そ、そうだ! これは奇跡…… なら、この奇跡を利用しない手はないんじゃ!」\",\"「奇跡? ……そ、そうだ! これは奇跡…… なら、この奇跡を利用しない手はないんじゃ!」\"],[\"player\",null,\"「利用……?」\",null,64,{\n"
+ " \"data\": [[\"bg\",\"stage\",{\n"
+ " \"action\": [[\"zpos\",233.33333333333337]],\n"
+ " \"class\": \"stage\",\n"
+ " \"name\": \"bg\",\n"
+ " \"redraw\": {\n"
+ " \"disp\": 2,\n"
+ " \"imageFile\": {\n"
+ " \"file\": \"bg03.mtn\",\n"
+ " \"options\": {\n"
+ " \"chara\": \"背景\",\n"
+ " \"motion\": \"昼\"\n"
+ " }\n"
+ " \n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}