import re
regex = re.compile(r"(?|(?<=null,)(.*?)(?=,null,(?:[0-9]{1,3})(?:,|$))|(?<=chara\":|motion\":)([^,\n]*))", flags=re.MULTILINE)
test_str = ("},null,\"「奇跡? ……そ、そうだ! これは奇跡…… なら、この奇跡を利用しない手はないんじゃ!」\",\"「奇跡? ……そ、そうだ! これは奇跡…… なら、この奇跡を利用しない手はないんじゃ!」\"],[\"player\",null,\"「利用……?」\",null,64,{\n"
" \"data\": [[\"bg\",\"stage\",{\n"
" \"action\": [[\"zpos\",233.33333333333337]],\n"
" \"class\": \"stage\",\n"
" \"name\": \"bg\",\n"
" \"redraw\": {\n"
" \"disp\": 2,\n"
" \"imageFile\": {\n"
" \"file\": \"bg03.mtn\",\n"
" \"options\": {\n"
" \"chara\": \"背景\",\n"
" \"motion\": \"昼\"\n"
" }\n"
" \n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")