#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\s?\+?\d{1,3}(\(|-|\s+)?\d+(\)|-|\s+)?(\d|-|\s)+\s?"
Local $sString = "+767 918 000-12-34"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")