package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\s?\+?\d{1,3}(\(|-|\s+)?\d+(\)|-|\s+)?(\d|-|\s)+\s?`)
var str = `+767 918 000-12-34`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}