using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?'type'[\w|\[\]\/]+)\s*\$(?'name'\w+)\s*(=\s*(?'default'[\w\'\\""]+)|)";
string input = @"string $arg1='klk', $arg2 = 222, boolean $eee= false, $arg4, $arg5=""fdsfds""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}