re = /(?'type'[\w|\[\]\/]+)\s*\$(?'name'\w+)\s*(=\s*(?'default'[\w\'\\"]+)|)/m
str = 'string $arg1=\'klk\', $arg2 = 222, boolean $eee= false, $arg4, $arg5="fdsfds"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end