use strict;
my $str = ' ..Some.. \'\' ';
my $regex = qr/^([^']*'[^']*)'/ip;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";