package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)TRN\*1\d*\*(\d+)`)
var str = `ENTRY DESCR:HCCLAIMPMTSEC:CCD TRACE#:04858562 TRN*1*6523251452*5865418282584~
ENTRY DESCR:HCCLAIMPMTSEC:CCD TRACE#:04526412 TRN*1*5685952452*158615*6526352 26\ TRN: 563569856`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}