re = /TRN\*1\d*\*(\d+)/m
str = 'ENTRY DESCR:HCCLAIMPMTSEC:CCD TRACE#:04858562 TRN*1*6523251452*5865418282584~
ENTRY DESCR:HCCLAIMPMTSEC:CCD TRACE#:04526412 TRN*1*5685952452*158615*6526352 26\\ TRN: 563569856'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end