use strict;
my $str = 'ENTRY DESCR:HCCLAIMPMTSEC:CCD TRACE#:04858562 TRN*1*6523251452*5865418282584~
ENTRY DESCR:HCCLAIMPMTSEC:CCD TRACE#:04526412 TRN*1*5685952452*158615*6526352 26\\ TRN: 563569856';
my $regex = qr`TRN\*1\d*\*(\d+)`mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}