using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"123(?:(?:(?P<test>(?:(?!789)[\s\S])*)456(?P<test1>(?P>test))789))";
string input = @"123aaaa456bbbb789
123aaaa456bb5bb789
123aaaa456bbbb78789";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}