re = /123(?:(?:(?P<test>(?:(?!789)[\s\S])*)456(?P<test1>(?P>test))789))/
str = '123aaaa456bbbb789
123aaaa456bb5bb789
123aaaa456bbbb78789'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end