$re = '/123(?:(?:(?P<test>(?:(?!789)[\s\S])*)456(?P<test1>(?P>test))789))/';
$str = '123aaaa456bbbb789
123aaaa456bb5bb789
123aaaa456bbbb78789';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);