using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d+)x(\d+)[ \.](.+)\..+";
string input = @"1x5 Girl In The Flower Dress.mkv
2x6.English,.Fitz.or.Percy.avi";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}