$re = '~(\d+)x(\d+)[ \.](.+)\..+~m';
$str = '1x5 Girl In The Flower Dress.mkv
2x6.English,.Fitz.or.Percy.avi';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);