// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\d+)x(\d+)[ \.](.+)\..+").unwrap();
let string = "1x5 Girl In The Flower Dress.mkv
2x6.English,.Fitz.or.Percy.avi";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}