#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!__(?!_).*[^_]__$)\w+$"
Local $sString = "_should_work_" & @CRLF & _
"__should_work___" & @CRLF & _
"_should_work___" & @CRLF & _
"__should_not_work__" & @CRLF & _
"" & @CRLF & _
"___should_work_but_doesnt__________"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")