const regex = /^(?!__(?!_).*[^_]__$)\w+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!__(?!_).*[^_]__$)\\w+$', 'gm')
const str = `_should_work_
__should_work___
_should_work___
__should_not_work__
___should_work_but_doesnt__________`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}