using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!__(?!_).*[^_]__$)\w+$";
string input = @"_should_work_
__should_work___
_should_work___
__should_not_work__
___should_work_but_doesnt__________";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}