package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.*\b\d{5}\b.*`)
var str = `12245
locations in 10002
12203 locations
122222020
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}