re = /^.*\b\d{5}\b.*/m
str = '12245
locations in 10002
12203 locations
122222020
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end