$re = '/^.*\b\d{5}\b.*/m';
$str = '12245
locations in 10002
12203 locations
122222020
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);