import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)(EDIResources\\/EDITradingPartnerUpdates\\.aspx)(.*)";
final String string = "www.1edisource.com/ediresources/editradingpartnerupdates.aspx?urlid=123\n"
+ "www.1edisource.com/ediresources/editradingpartnerupdates.aspx?urlid=123&gclid=jjj\n"
+ "www.1edisource.com/ediresources/editradingpartnerupdates.aspx\n"
+ "www.1edisource.com/ediresources/editradingpartnerupdates.aspx?gclid=jjj";
final String subst = "resources/edi-tips$2";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}