import re
regex = re.compile(r"(?i)(EDIResources\/EDITradingPartnerUpdates\.aspx)(.*)", flags=re.IGNORECASE)
test_str = ("www.1edisource.com/ediresources/editradingpartnerupdates.aspx?urlid=123\n"
"www.1edisource.com/ediresources/editradingpartnerupdates.aspx?urlid=123&gclid=jjj\n"
"www.1edisource.com/ediresources/editradingpartnerupdates.aspx\n"
"www.1edisource.com/ediresources/editradingpartnerupdates.aspx?gclid=jjj")
subst = "resources/edi-tips$2"
result = regex.sub(subst, test_str)
if result:
print(result)