package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\+?(?:[ -]*\d)+$`)
var str = `123-456-678
123 445 6788
+123 445 6788
+123 - - 445-6788`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}