re = /^\+?(?:[ -]*\d)+$/m
str = '123-456-678
123 445 6788
+123 445 6788
+123 - - 445-6788'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end