$re = '~^\+?(?:[ -]*\d)+$~m';
$str = '123-456-678
123 445 6788
+123 445 6788
+123 - - 445-6788';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);