import re
regex = re.compile(r"^[A-Za-z,.'-]{2,} +[A-Za-z,.'-]{2,}$", flags=re.MULTILINE)
test_str = ("firstname\n"
"Lastname\n"
"F lastname\n"
"firstname l\n"
"Firstname Lastname\n"
"f-name lastname\n"
"someguy en'try\n"
"Patrick O'Brian\n"
"web dev@\n"
"'f names\n"
"Mr. Bean\n"
".hidden file")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")