re = /^[A-Za-z,.'-]{2,} +[A-Za-z,.'-]{2,}$/m
str = 'firstname
Lastname
F lastname
firstname l
Firstname Lastname
f-name lastname
someguy en\'try
Patrick O\'Brian
web dev@
\'f names
Mr. Bean
.hidden file'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end