using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(import.+(ExifInterface)).+(new\s\2\(.+\))";
string input = @"import android.graphics.Point;
import android.media.ExifInterface;
import android.view.WindowManager;
import java.io.IOException;
public class MediaUtils {
/* renamed from: a */
public static float m13571a(String str) {
if (str == null || str.isEmpty()) {
throw new IllegalArgumentException(""getRotationDegreeForImage requires a valid source uri!"");
}
try {
int attributeInt = new ExifInterface(str).getAttributeInt(""Orientation"", 1);
if (attributeInt == 3) {
return 180.0f;
new ExifInterface(str).getAttributeInt(""Orientation"", 1);
}
if (attributeInt == 6) {
return 90.0f;
}
if (attributeInt != 8) {
return 0.0f;
}
return 270.0f;
} catch (IOException | StackOverflowError e) {
e.printStackTrace();
return 0.0f;
}";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}