import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(import.+(ExifInterface)).+(new\\s\\2\\(.+\\))";
final String string = "import android.graphics.Point;\n"
+ "import android.media.ExifInterface;\n"
+ "import android.view.WindowManager;\n"
+ "import java.io.IOException;\n\n"
+ "public class MediaUtils {\n"
+ " /* renamed from: a */\n"
+ " public static float m13571a(String str) {\n"
+ " if (str == null || str.isEmpty()) {\n"
+ " throw new IllegalArgumentException(\"getRotationDegreeForImage requires a valid source uri!\");\n"
+ " }\n"
+ " try {\n"
+ " int attributeInt = new ExifInterface(str).getAttributeInt(\"Orientation\", 1);\n"
+ " if (attributeInt == 3) {\n"
+ " return 180.0f;\n"
+ "new ExifInterface(str).getAttributeInt(\"Orientation\", 1);\n"
+ " }\n"
+ " if (attributeInt == 6) {\n"
+ " return 90.0f;\n"
+ " }\n"
+ " if (attributeInt != 8) {\n"
+ " return 0.0f;\n"
+ " }\n"
+ " return 270.0f;\n"
+ " } catch (IOException | StackOverflowError e) {\n"
+ " e.printStackTrace();\n"
+ " return 0.0f;\n"
+ " }";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.UNICODE_CHARACTER_CLASS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}