# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(import.+(ExifInterface)).+(new\s\2\(.+\))"
test_str = ("import android.graphics.Point;\n"
"import android.media.ExifInterface;\n"
"import android.view.WindowManager;\n"
"import java.io.IOException;\n\n"
"public class MediaUtils {\n"
" /* renamed from: a */\n"
" public static float m13571a(String str) {\n"
" if (str == null || str.isEmpty()) {\n"
" throw new IllegalArgumentException(\"getRotationDegreeForImage requires a valid source uri!\");\n"
" }\n"
" try {\n"
" int attributeInt = new ExifInterface(str).getAttributeInt(\"Orientation\", 1);\n"
" if (attributeInt == 3) {\n"
" return 180.0f;\n"
"new ExifInterface(str).getAttributeInt(\"Orientation\", 1);\n"
" }\n"
" if (attributeInt == 6) {\n"
" return 90.0f;\n"
" }\n"
" if (attributeInt != 8) {\n"
" return 0.0f;\n"
" }\n"
" return 270.0f;\n"
" } catch (IOException | StackOverflowError e) {\n"
" e.printStackTrace();\n"
" return 0.0f;\n"
" }")
matches = re.finditer(regex, test_str, re.DOTALL)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.