import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?m)(?:\\d+\\.){3}\\d+$";
final String string = "4:16:09PM - xx yy DOS activity from 10.0.0.45\n"
+ "9:43:44PM - xx yy 1A disconnected from server\n"
+ "2:40:28AM - xx yy 1A connected\n"
+ "1:21:52AM - xx yy DOS activity from 192.168.123.4";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}