import re
regex = re.compile(r"(?m)(?:\d+\.){3}\d+$")
test_str = ("4:16:09PM - xx yy DOS activity from 10.0.0.45\n"
"9:43:44PM - xx yy 1A disconnected from server\n"
"2:40:28AM - xx yy 1A connected\n"
"1:21:52AM - xx yy DOS activity from 192.168.123.4")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")