#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)eventtype="(?<group>administrator)",username="(?<login>.*?)",action="(?<vmid>(?<action>.*?))",object="(?<object>(?<account>.*?))",description="{(?:.*)?,."status":."(?<status>.*)\"}""
Local $sString = "" & @CRLF & _
"1597750344,host="api-437dca50.duosecurity.com",eventtype="administrator",username="Billy BA",action="Update User",object="batman",description="{"notes": "Locked keyfob in office and no spare key.", "status": "Bypass"}"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")