package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)eventtype="(?<group>administrator)",username="(?<login>.*?)",action="(?<vmid>(?<action>.*?))",object="(?<object>(?<account>.*?))",description="{(?:.*)?,."status":."(?<status>.*)\"}"`)
var str = `
1597750344,host="api-437dca50.duosecurity.com",eventtype="administrator",username="Billy BA",action="Update User",object="batman",description="{"notes": "Locked keyfob in office and no spare key.", "status": "Bypass"}"
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}